Kuinka ratkaista riippuvuudet ohjelmiston kääntämisessä Ubuntussa

Geoffrey_Carr

Sisällysluettelo:

Kuinka ratkaista riippuvuudet ohjelmiston kääntämisessä Ubuntussa - Blogi 2023
Kuinka ratkaista riippuvuudet ohjelmiston kääntämisessä Ubuntussa - Blogi 2023
Anonim
Vaikein osa ohjelmistojen kääntämisestä Linuxissa on löytää riippuvuudet ja asentaa ne. Ubuntuilla on käytössään komentoja, jotka havaitsevat, paikantaa ja asentavat riippuvuudet automaattisesti ja tekevät kovaa työtä puolestasi.
Vaikein osa ohjelmistojen kääntämisestä Linuxissa on löytää riippuvuudet ja asentaa ne. Ubuntuilla on käytössään komentoja, jotka havaitsevat, paikantaa ja asentavat riippuvuudet automaattisesti ja tekevät kovaa työtä puolestasi.

Olemme äskettäin tutkinneet ohjelmistojen kääntämisen perusteet Ubuntun lähteestä, joten tutustu alkuperäiseen artikkeliin, jos olet vasta aloittanut.

Auto-Apt

Auto-apt tarkkailee ja odottaa, kun suoritat./configure-komennon sen kautta. Kun./configure yrittää käyttää tiedostoa, jota ei ole olemassa, auto-apt asettaa./configure-prosessin pitoon, asentaa sopivan paketin ja jatkaa./configure-prosessi.

Ensin asenna auto-apt seuraavalla komennolla:

sudo apt-get install auto-apt

Kun se on asennettu, suorita seuraava komento ladataksesi tiedoston, jonka se automaattisesti edellyttää. Tämä prosessi kestää muutaman minuutin.
Kun se on asennettu, suorita seuraava komento ladataksesi tiedoston, jonka se automaattisesti edellyttää. Tämä prosessi kestää muutaman minuutin.

sudo auto-apt update

Kun ensimmäinen komento on suoritettu, suorita seuraavat komennot tietokantojen päivittämiseksi. Nämä komennot kestää myös muutaman minuutin.
Kun ensimmäinen komento on suoritettu, suorita seuraavat komennot tietokantojen päivittämiseksi. Nämä komennot kestää myös muutaman minuutin.

sudo auto-apt updatedb && sudo auto-apt update-local

Kun olet tehnyt auto-aptin tietokantojen rakentamisen, voit aloittaa./configure-prosessin seuraavalla komennolla:
Kun olet tehnyt auto-aptin tietokantojen rakentamisen, voit aloittaa./configure-prosessin seuraavalla komennolla:

sudo auto-apt run./configure

Image
Image

Apt-tiedosto

Jos näet virheilmoituksen, jossa kerrotaan, että tietty tiedosto puuttuu, et välttämättä tiedä paketista, jonka haluat asentaa tiedoston hankkimiseksi. Apt-tiedoston avulla voit löytää paketit, jotka sisältävät tietyn tiedoston yhdellä komennolla.

Ensin sinun on asennettava apt-tiedosto itse:

sudo apt-get install apt-file

Kun se on asennettu, suorita seuraava komento ladataksesi tiedostojen luettelot konfiguroiduista apt-arkistoista. Nämä ovat suuria listoja, joten niiden lataaminen kestää muutaman minuutin.
Kun se on asennettu, suorita seuraava komento ladataksesi tiedostojen luettelot konfiguroiduista apt-arkistoista. Nämä ovat suuria listoja, joten niiden lataaminen kestää muutaman minuutin.

sudo apt-file update

Image
Image

Suorita seuraava komento, korvaa "example.pc"Tiedostonimellä ja komennolla kerrotaan tarkalleen mitä pakettia sinun on asennettava:

apt-file search file example.pc

Asenna paketti tavallisella apt-get-asennuskomennolla:
Asenna paketti tavallisella apt-get-asennuskomennolla:

sudo apt-get install package

Voit myös tehdä tiedostonhaun Ubuntun pakettihaun verkkosivustosta. Käytä "Etsi pakkausten sisältöä"-Osiossa sivun etsiäksesi tiettyä tiedostoa.

Se antaa sinulle samanlaisia tuloksia kuin apt-tiedosto, eikä sinun tarvitse ladata tiedostoja.
Se antaa sinulle samanlaisia tuloksia kuin apt-tiedosto, eikä sinun tarvitse ladata tiedostoja.
Image
Image

Apt-Get Build-Dep

Katseimme apt-get build-dep alkuperäiseen viestiimme. Jos aiemmin asennettavan ohjelman aiempi versio on jo Ubuntun pakettivarastoissa, Ubuntu tietää jo tarvittavat riippuvuudet.

Kirjoita seuraava komento, korvaa "paketti"Pakkauksen nimellä ja apt-get asentaa tarvittavat riippuvuudet:

sudo apt-get build-dep package

Apt-get kehottaa asentamaan kaikki tarvittavat riippuvuudet.
Apt-get kehottaa asentamaan kaikki tarvittavat riippuvuudet.
Jos uudempi versio ohjelmasta vaatii erilaisia riippuvuuksia, sinun on ehkä asennettava joitain ylimääräisiä riippuvuuksia käsin.
Jos uudempi versio ohjelmasta vaatii erilaisia riippuvuuksia, sinun on ehkä asennettava joitain ylimääräisiä riippuvuuksia käsin.

Kaikki nämä komennot käyttävät apt-get -ohjelmaa, joten voit myös käyttää niitä Debianilla, Linux Mintilla ja muilla Linux-jakeluilla, jotka käyttävät apt-get- ja.deb-paketteja.

Suosittu aihe