Skip to main content

Kuinka katsella Hulu Ubuntussa ja muissa Linux-jakeluissa

Kuinka katsella Hulu Ubuntussa ja muissa Linux-jakeluissa

Geoffrey Carr

Hulu ei toimi vanhanaikaisissa Linux-jakeluissa. Vaikka Netflix "toimii vain", jos käytät Google Chromea, Hulu: n DRM-versio on vanhentunut. Voit hankkia Hulun toimimaan Linuxissa, mutta se vie hieman muokkausta.

Se ei ollut aina niin kovaa. Takaisin, kun Netflix teki elämän kovaksi Linux-käyttäjille, Hulu tarjosi jopa Linux-työpöytäsovelluksen. Mutta työpöytäsovellus on nyt lopetettu. Hulu luottaa Adobe Flashen, ja Adobe Flash DRM-koodi hajoaa Linuxissa.

Sinun on käytettävä Firefoxia

Tässä on ongelma: Hulu luo vanhan Adobe Flash DRM -koodin, joka vaatii Linux-kirjastosta nimeltä HAL. Tämä vanha HAL-ohjelmisto on kuitenkin melko vanhentunut, eikä sitä ole asennettu oletuksena nykyaikaisilla Linux-jakeluilla jo vuosikausia. Sinun on asennettava yhteensopivuuspaketit, joiden avulla tämä HAL-pohjainen DRM-toiminto toimisi.

Sinun on myös käytettävä Mozilla Firefoxia katsoaksesi Hulu. Vanha HAL-pohjainen DRM toimii vain Linuxin Flash-laajennuksen Firefoxin vanhemmassa versiossa. Uudempi PPAPI (Pepper API) -pohjainen Flash Player, joka sisältyy Google Chromeon, ei toimi Hulu vanhan DRM-koodin kanssa.

Kyllä, tämä tarkoittaa, että sinun on katsottava Netflixia Google Chromessa ja Hulussa Mozilla Firefoxissa. Eikö elämä ole suurta?

Vaihe yksi: Asenna Flash for Firefox

Ensinnäkin sinun on asennettava Firefoxin Flash Player -laajennus. Jos et ole vielä asentanut Flasha, näet viestin, jossa sanotaan, että Hulu tarvitsee Flash-asennuksen, kun yrität katsella sitä.

Voit yleensä asentaa Flash-levyn Linux-jakeluohjelmistosi ohjelmistovarastoista. Esimerkiksi Ubuntu, avaa Ubuntu Software Center ja etsi "flash". Asenna "Adobe Flash plug-in" -ohjelmisto.

Varmista, että asennat Flash-laajennuksen, joka on suunniteltu "Mozilla," "Firefoxille" tai laajennuksen "NPAPI" -versio. Flashin PPAPI- tai "Chromium" -versio toimii vain Chrome- ja Chromium-pohjaisilla selaimilla.

Vaihe kaksi: Asenna vanha HAL-kirjasto

Kun sinulla on Firefox ja Flash-plug-in for Firefox asennettuna, voit päästä Hulun verkkosivustoon ja kokeilla videon toistamista. Näet kuitenkin todennäköisesti virheilmoituksen, kun teet niin. Virheilmoitus sanoo, että tämä suojattu sisältö oli ongelma. (Virhekoodi: 2203) ". Hulu pyytää sinua varmistamaan, että HAL-paketti on asennettu, tyhjennä flash-välimuisti ja nollaa lisenssitiedostot.

Hulu linkittää sinut Adoben sivulle, joka suosittelee paketin "hal" asennusta, mutta tämä paketti ei ole enää läsnä asennettavaksi nykyaikaisiin Ubuntun ja muiden nykyaikaisten Linux-versioiden versioihin.

Sen sijaan, että asennat koko HAL-paketin version - zombie HAL PPA: sta, koska se tunnetaan Ubuntun piireissä - ohjataan sinut kevyempään ratkaisuun.

Martin Wimpress, projektin johto Ubuntu MATE: lle, tarjoaa "hal-flash" PPA: n, joka tarjoaa kaiken mitä tarvitset DRM-suojatun Flash-sisällön toistamiseen ilman koko HAL-kerroksen asennusta.

Tämän ohjelmiston asentamiseksi sinun on lisättävä tämä PPA Ubuntu -järjestelmään (tämä pitäisi myös toimia Linux Mintilla ja muilla Ubuntu-johdannaisilla). Avaa terminaali viivalta ja liitä tai kirjoita seuraavat komennot järjestyksessä, paina Enter jokaisen jälkeen. Ensimmäinen komento lisää PPA: n, toinen lataa tiedot paketeista siinä ja kolmas asentaa HAL-kirjaston.

sudo add-apt-repository ppa:flexiondotorg/hal-flash sudo apt-get update sudo apt-get install libhal1-flash

Jos käytät toista Linux-jakelua - eli jotain muuta kuin Ubuntu, Linux Mint tai jotain Ubuntun johdosta - sinun on etsittävä Linux-jakeluun tarkoitettu Flash-paketti HAL-paketti. Se voi olla osa Linux-jakeluasi pakettivarastoja, tai se saattaa olla kolmannen osapuolen arkistossa, kuten Ubuntun tapauksessa.

Kun tämä on asennettu, käy Hulu Firefoxissa, yritä toistaa videota uudelleen, ja sen pitäisi nyt toimia sen sijaan, että näyttäisit sinulle suojatun sisällön virhesanoman.

Jos näet edelleen virheilmoituksen, saatat joutua sulkemaan Firefoxin ja käynnistämään sen uudelleen. Jos tämä ei toimi, yritä käynnistää tietokone uudelleen kokonaan, ennen kuin jatkat.


Tämä on ollut ongelma monien vuosien ajan. Adoben sivu kertoo, että HAL on asennettava versioihin 10.x ja uudempiin Ubuntu-versioihin - joka viittaa Ubuntun versioksi, joka julkaistiin loppuvuodesta 2010.

Adobe ei enää halua kehittää Flasha Linuxissa. Todellinen ratkaisu täällä ei tule, kun Adobe vahvistaa Flash DRM: n. Sen sijaan Hulu tarvitsee siirtyä nykyaikaiseen HTML5-pohjaiseen videotoistoon, kuten Netflix käyttää Google Chromessa. Niin kauan kuin Linux on, Linux-toisto on hieman haastavaa.

Link
Plus
Send
Send
Pin